Back to overview
Degraded
Email delivery rate limiting
Apr 17, 2026 at 1:36pm UTC
Affected services
Website - https://joulo.nl
Resolved
Apr 17, 2026 at 1:54pm UTC
The root cause of the email rate limiting issue has been identified, and signups are now fully operational again.
Affected services
Created
Apr 17, 2026 at 1:36pm UTC
Users can't complete signups because email delivery was being rate limited. Ruben Stolk acknowledged the issue and confirmed it was resolved shortly after, restoring normal signup and email delivery.
Affected services